Enable oauth on Mac OS 10.6

First posted on the 25th June, 2011 – IT
Last modified on the 31st January, 2014, at 4:02 pm

In order to allow access to the LinkedIn API the oauth module is needed in PHP. The default configuration released with Mac OS 10.6 does not come with this. This can be seen by seeing if this module is listed in the php info.
phpinfo.php

The easiest way I found to described here using homebrew.

The following assumes Xcode has been installed.

Install homebrew from withing bash:
ruby -e "$(curl -fsSL https://raw.github.com/gist/323731)"
brew install pcre
sudo pecl install oauth

Load the extension by add the following line to the php.ini file in /etc/
extensions=oauth

Restart apatche
sudo /usr/sbin/apachectl restart

Update: not needed as plugin will load an included library.