Xcode and 10.8

First posted on the 28th July, 2012 – IT
Last modified on the 28th July, 2012, at 12:17 am

When trying to install Xcode on OS 10.8 gave me an error stating OS was too new.

Problem can be solved by clearing the preferences and caches of the MacAppStore.app using these commands:

rm ~/Library/Preferences/com.apple.appstore.plist
rm -r ~/Library/Saved\ Application\ State/com.apple.appstore.savedState
rm -r ~/Library/Caches/com.apple.appstore
rm -r /private/var/folders/*/*/*/com.apple.appstore